How to embed videos in the grimrock forum

Announcements and discussion regarding the forums.
Post Reply
User avatar
Sol_HSA
Posts: 681
Joined: Fri Mar 02, 2012 3:10 pm
Location: Nowhere whenever
Contact:

How to embed videos in the grimrock forum

Post by Sol_HSA » Tue Oct 15, 2013 7:12 am

You can embed videos like this:

[flash=600,400]http://youtube.com/v/kGQdUhvc7jU[/flash]
Reminder: moderators (green names) don't work for almost human. | http://iki.fi/sol/ - My schtuphh..

User avatar
Sol_HSA
Posts: 681
Joined: Fri Mar 02, 2012 3:10 pm
Location: Nowhere whenever
Contact:

Re: Welcome to the Grimrock2 subforum!

Post by Sol_HSA » Tue Oct 15, 2013 7:12 am

The above, with BBCode enabled:

Reminder: moderators (green names) don't work for almost human. | http://iki.fi/sol/ - My schtuphh..

FlashSoul
Posts: 125
Joined: Mon Apr 16, 2012 9:20 pm

Re: How to embed videos in the grimrock forum

Post by FlashSoul » Wed Oct 16, 2013 5:40 am

That's neat. I just want to report that the "Watch on youtube" button doesn't work for me (FF24 and Chrome). I don't know if it's an issue with Google's API, the forum's handling of it or somehow a browser problem on FF and Chrome but I had to report it!

EDIT : Also, you get the error message "You cannot use certain BBCodes: [flash]." if you try to embed. It's certainly a permission issue.

User avatar
antti
Posts: 685
Joined: Thu Feb 23, 2012 1:43 pm
Location: Espoo, Finland
Contact:

Re: How to embed videos in the grimrock forum

Post by antti » Wed Oct 16, 2013 9:50 am

The permission issue should now be fixed. 8-)
Steven Seagal of gaming industry

User avatar
Leki
Posts: 548
Joined: Wed Sep 12, 2012 3:49 pm

Re: How to embed videos in the grimrock forum

Post by Leki » Wed Oct 16, 2013 12:32 pm

Thanks a lot antti. I know you have more important work to do... But still - if you have a minnute, check it again please... I can se only white rectangle (flash iframe probably in size 320x200). No adblocks, In FF and Chrome and IE I can see the same - an on the different PC as well...

Sol_HSA's "tutorial" video (dunno if it's standard youtube). Try to click here (it's yours working video url): http://youtube.com/v/kGQdUhvc7jU and it will redirect you.. :shock:



Sol_HSA's youtube video, embed here:



Leki's video embed here:

I'm the Gate I'm the Key.
Dawn of Lore

User avatar
antti
Posts: 685
Joined: Thu Feb 23, 2012 1:43 pm
Location: Espoo, Finland
Contact:

Re: How to embed videos in the grimrock forum

Post by antti » Wed Oct 16, 2013 12:54 pm

Leki wrote:Thanks a lot antti. I know you have more important work to do... But still - if you have a minnute, check it again please... I can se only white rectangle (flash iframe probably in size 320x200). No adblocks, In FF and Chrome and IE I can see the same - an on the different PC as well...
You need to format the URL a little differently to get the embedding to work. Instead of linking to the whole video page (with all the comments and whatnot) you need to link directly to the flash video like so:

Code: Select all

This is the correct way: [flash=320,200]http://www.youtube.com/v/KGdx15KM9mc[/flash]
This won't work: [flash=320,200]http://www.youtube.com/watch?v=KGdx15KM9mc[/flash]
And here's how your video will look:


You can get the embeddable URL from a video if you go to Embed -> Use old embed code. From there, don't copy the whole block, just that URL. It's also pretty easy to format the youtube video page URL by hand too by replacing "watch?v=" with "v/".

I hope this helps! :)
Steven Seagal of gaming industry

User avatar
Leki
Posts: 548
Joined: Wed Sep 12, 2012 3:49 pm

Re: How to embed videos in the grimrock forum

Post by Leki » Wed Oct 16, 2013 1:06 pm

antti wrote:
Leki wrote:Thanks a lot antti. I know you have more important work to do... But still - if you have a minnute, check it again please... I can se only white rectangle (flash iframe probably in size 320x200). No adblocks, In FF and Chrome and IE I can see the same - an on the different PC as well...
You need to format the URL a little differently to get the embedding to work. Instead of linking to the whole video page (with all the comments and whatnot) you need to link directly to the flash video like so:

Code: Select all

This is the correct way: [flash=320,200]http://www.youtube.com/v/KGdx15KM9mc[/flash]
This won't work: [flash=320,200]http://www.youtube.com/watch?v=KGdx15KM9mc[/flash]
And here's how your video will look:


You can get the embeddable URL from a video if you go to Embed -> Use old embed code. From there, don't copy the whole block, just that URL. It's also pretty easy to format the youtube video page URL by hand too by replacing "watch?v=" with "/v/".

I hope this helps! :)
Hmm...
I already tried to do "/v/" before I asked for an assistance - as you can see it in my Monsters threat:
viewtopic.php?f=14&t=5230&p=63810#p63810
And I got that white rectangle, but now you can see the video without issue... so why it didn't work is behind my understanding :roll:

Anyway thanks a lot and have a nice day! :D
I'm the Gate I'm the Key.
Dawn of Lore

Post Reply