Blender 2.71 - Importer / Exporter (1.4.4)

Ask for help about creating mods and scripts for Grimrock 2 or share your tips, scripts, tools and assets with other modders here. Warning: forum contains spoilers!
DrVooDoo
Posts: 17
Joined: Fri Dec 21, 2012 10:49 pm

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by DrVooDoo » Tue Jul 07, 2015 10:03 am

What of this i must scale? Multiple? I trying, but nothing changes.
SpoilerShow
Image
ps
Nothing more, i did it.

User avatar
akroma222
Posts: 1024
Joined: Thu Oct 04, 2012 10:08 am

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by akroma222 » Wed Jul 29, 2015 9:51 am

Hey bitcpy & folks,
Very simple/easy question from me, I have only just installed Blender 2.75 - and want to use this Importer/exporter (total Blender newb)
I have followed the links from the OP to

the latest downloadable version https://sites.google.com/site/bitcpy/download
and the paste-bin http://pastebin.com/5S0a32FL

...but I have no idea where these things should go
Help?

User avatar
Isaac
Posts: 2943
Joined: Fri Mar 02, 2012 10:02 pm

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by Isaac » Wed Jul 29, 2015 2:50 pm

I need to install 2.75

*Offhand I would say copy the script here:
"C:\Program Files\Blender 3D\275\2.75\scripts\addons"

User avatar
akroma222
Posts: 1024
Joined: Thu Oct 04, 2012 10:08 am

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by akroma222 » Thu Jul 30, 2015 9:33 am

Awesome Isaac, makes sense haha.... done...
Need to put that paste-bin code somewhere too I assume... not sure where! :oops: :?

User avatar
Isaac
Posts: 2943
Joined: Fri Mar 02, 2012 10:02 pm

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by Isaac » Sat Aug 01, 2015 8:02 am

So far, every model I've imported from the LOG2 asset pact, has imported deformed. The animation can also be loaded well enough it seems, but the model remains all stretched out.

edit: Using version 2.75 ;)
(Have also tried 2.74)
Last edited by Isaac on Mon Aug 03, 2015 5:37 am, edited 2 times in total.

User avatar
maneus
Posts: 230
Joined: Mon Jun 17, 2013 10:42 pm
Location: Switzerland

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by maneus » Sat Aug 01, 2015 10:17 am

For me all models are imported correctly, but I use Blender 2.70.

But I have a big problem importing the Goromorg model from Grimrock 1.
Every time I´ve imported the Goromorg model from the Grimrock 1 game into Blender and go into the Edit-mode
and then click on a triangle face or a edge on the model then Blender is freezing and crash.
Same problem with the "Cultist" custom model.
Have anyone a idea how to solve this?

minmay
Posts: 2654
Joined: Mon Sep 23, 2013 2:24 am

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by minmay » Tue Apr 26, 2016 9:10 am

So I just noticed that Blender 2.74 added support for custom normals. Furthermore, RootNode seems to import with incorrect transforms in recent Blender versions.
I'm going to try to add normal importing and fix that RootNode problem myself.
Grimrock 1 dungeon
Grimrock 2 resources
I no longer answer scripting questions in private messages. Please ask in a forum topic or this Discord server.

User avatar
juho
Posts: 238
Joined: Mon Feb 27, 2012 1:18 pm

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by juho » Thu Apr 28, 2016 10:57 am

I find the custom normal tools in Blender a bit limited. But fear not, "notallowed" in blenderartist.org forum has created a Weighted Normals addon. I think it pretty much solved most of my problems with normals in Blender. Visit the thread here
Follow me on Twitter: @JuhoMakingStuff

kelly1111
Posts: 316
Joined: Sun Jan 20, 2013 6:28 pm

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by kelly1111 » Tue Apr 10, 2018 2:46 pm

Question: where do I put the script?
And is it compatible with blender 2.79b ?

User avatar
Isaac
Posts: 2943
Joined: Fri Mar 02, 2012 10:02 pm

Re: Blender 2.71 - Importer / Exporter (1.4.4)

Post by Isaac » Tue Apr 10, 2018 4:40 pm

As far as I recall, it is reasonably reliable on Blender 2.71 through 2.73— I think. :? I use Blender 2.72 with the script.

On later versions I see mesh/ or animation corruption. Just download an earlier version from Blender.org. They have them all available. I have a dedicated separate install of Blender, just for LoG modeling. It has its own renamed shortcut to identify it.

The script can go in the scripts\addons_contrib folder. Once installed, (and enabled!), you get separate import and export options for LoG model and animation files.

Post Reply