Ask a simple question, get a simple answer

Ask for help about creating mods and scripts for Grimrock 2 or share your tips, scripts, tools and assets with other modders here. Warning: forum contains spoilers!
User avatar
Eleven Warrior
Posts: 704
Joined: Thu Apr 18, 2013 2:32 pm
Location: Australia

Re: Ask a simple question, get a simple answer

Post by Eleven Warrior » Sun Nov 03, 2019 10:55 am

How do I spawn a particle at a location? The name of the particle I have is called: wisp_death.

Slayer82
Posts: 279
Joined: Thu Feb 05, 2015 10:19 am

Re: Ask a simple question, get a simple answer

Post by Slayer82 » Mon Nov 11, 2019 6:57 am

Hey, everyone.

I have the game, as well as 'The Allure of Nightfall' updated to the latest version on WIndows (2.2.4),
but some of my lua files for 'Isle of the Deranged' state that they 'have been generated by Dungeon Editor 2.1.9'.

Is there a way to update these files without affecting the information contained in them?
Any help would be appreciated.

Cheers.
Mods - Isle of the Deranged & The Allure of Nightfall
http://grimrock.net/forum/viewtopic.php?f=23&t=9513
viewtopic.php?f=23&t=14762

User avatar
THOM
Posts: 1036
Joined: Wed Nov 20, 2013 11:35 pm
Location: Germany - Cologne
Contact:

Re: Ask a simple question, get a simple answer

Post by THOM » Mon Nov 11, 2019 10:12 am

You mean the files that are generated if you start a new project in the editor?

And that start with the line
-- This file has been generated by Dungeon Editor 2.2.4

I don't know if there is an error in the code that prints out that line, I don't know if you may have generated the files with an older version before you updated the game - but it doesn't make any difference which version generated the files. The program will read the code anyway.

And you can delete that line everywhere you find it. It's not needed.
THOM formaly known as tschrage
_______________________________________________
My MOD (LoG1): Castle Ringfort Thread
My MOD (LoG2): Journey To Justice Thread | Download

Slayer82
Posts: 279
Joined: Thu Feb 05, 2015 10:19 am

Re: Ask a simple question, get a simple answer

Post by Slayer82 » Mon Nov 11, 2019 10:26 am

Thanks, THOM.
I know that the double hyphen excludes the code being read, I just wanted to know if the generated version number affected it.

The reason why I asked was because the Multi-Alcove Manager (MAM) hooks aren't working with Isle of the Deranged,
but they are with The Allure of Nightfall.
The armours/shields et cetera are hung properly (displayed) in Allure, but not in Isle.
I thought the generated message was affecting it, but I still don't know what the issue is.

Anyway, thanks for the feedback.
Mods - Isle of the Deranged & The Allure of Nightfall
http://grimrock.net/forum/viewtopic.php?f=23&t=9513
viewtopic.php?f=23&t=14762

minmay
Posts: 2574
Joined: Mon Sep 23, 2013 2:24 am

Re: Ask a simple question, get a simple answer

Post by minmay » Mon Nov 11, 2019 11:46 am

Slayer82 wrote:
Mon Nov 11, 2019 10:26 am
I know that the double hyphen excludes the code being read, I just wanted to know if the generated version number affected it.
It does not.
Grimrock 1 dungeon
Grimrock 2 resources
I no longer answer scripting questions in private messages. Please ask in a forum topic or this Discord server.

Slayer82
Posts: 279
Joined: Thu Feb 05, 2015 10:19 am

Re: Ask a simple question, get a simple answer

Post by Slayer82 » Mon Nov 11, 2019 12:01 pm

Cool, Minmay. That's helpful.

Luckily, your answer has solved my problem.

Anyway, AdrTru has not been online for several months, so has anyone experienced this problem, and do they have a solution?
Mods - Isle of the Deranged & The Allure of Nightfall
http://grimrock.net/forum/viewtopic.php?f=23&t=9513
viewtopic.php?f=23&t=14762

ColdDeadStone
Posts: 19
Joined: Sat Nov 26, 2016 12:12 pm

Re: Ask a simple question, get a simple answer

Post by ColdDeadStone » Wed Nov 13, 2019 8:42 am

Hello! I have a simple question: How can I use the German umlauts (mutated vowel) in Grimrock 2? I can use Ö + ö and Ä + ä but not Ü + ü... I can't even type them in the editor, when I press the button, nothing happens. And a written "ü" in a string from a defineObject for example is also not displayed. Does this have anything to do with the dungeon.lua format? UTF-8, ANSI or anything? I can write anything except the "Ü" and "ü" :?:
Sorry for my poor english... hope you understand what i try to say! :)

User avatar
Isaac
Posts: 2865
Joined: Fri Mar 02, 2012 10:02 pm

Re: Ask a simple question, get a simple answer

Post by Isaac » Wed Nov 13, 2019 8:54 am

I don't believe that you can... There are many symbols lacking from what LoG2 will print. While it is probably possible to print a custom image via graphics commands—that is likely far too much hassle to be worth doing it. It would involve creating the missing letters to match the font, and using the GUI drawImage command... and accounting for whatever screen-size the player is using. :shock:

The easiest way to get [limited] custom lettering into the game would be to use a textured 3D model component placed on the party, such that enabling it would make the flat plane model appear in front of the player using a custom material image of the words; disabling it makes it invisible. The texture would have the custom words you want printed; it would be possible to swap out model, or UV positions via script (to affect changes to the text). This is STILL a lot of hassle.

______________

Alternatively... it might be possible to add the dots via graphics command, or via escape string symbols. :?

ColdDeadStone
Posts: 19
Joined: Sat Nov 26, 2016 12:12 pm

Re: Ask a simple question, get a simple answer

Post by ColdDeadStone » Wed Nov 13, 2019 9:26 am

Instead of "Ü + ü" I can also write "UE + ue" which I actually do. I just wondered why of precisely the "Ü" doesn't work while there is no problem with the "Ä" or "Ö". But I would need the "Ü" for all sorts of things like "defineTrait", "defineSkill", "item description & gameEffect" and so on and not only for HudPrints or walltexts. I guess i have to live with UE + ue... looks stupid in german but well...

Okay then, thanks for replying! :)
Tschüss! (or grimrock style) Tschuess!
Sorry for my poor english... hope you understand what i try to say! :)

minmay
Posts: 2574
Joined: Mon Sep 23, 2013 2:24 am

Re: Ask a simple question, get a simple answer

Post by minmay » Wed Nov 13, 2019 9:45 am

Ä and Ö are part of the Finnish alphabet. Ü is not, and isn't included in Grimrock's fonts.
Grimrock 1 dungeon
Grimrock 2 resources
I no longer answer scripting questions in private messages. Please ask in a forum topic or this Discord server.

Post Reply