Launch issue

Have trouble running Legend of Grimrock 2 or do you have questions about the purchasing options? Look for help here.
Post Reply
Culturegeek
Posts: 9
Joined: Thu Apr 02, 2015 8:25 pm

Launch issue

Post by Culturegeek » Wed Oct 03, 2018 4:55 pm

I've had the game for years. I was revisiting it, and one day, it just stopped launching.
The topics I had found on the non-launch issue have generally involved a respondent request for a log file in documents\Almost Human\Legend of Grimrock 2. That file was not present, but there is a gtimrock.txt.

Any help will be appreciated. Contents of grimrock.txt follow:

=== System Info ===

Game Version: 2.2.4
Computer name: DESKTOP-RJ0A86M
CPU Vendor: GenuineIntel
CPU Brand: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
OS Version: 6.2
OEM ID: 0
Physical CPUs: 8
Logical CPUs: 0
Page Size: 4096
Total Mem: 16244 MB
Free Mem: 7888 MB

=== GPUs ===

Device name: \\.\DISPLAY1
Device string: AMD Radeon R7 200 Series
State flags: 00000005

Device name: \\.\DISPLAY2
Device string: AMD Radeon R7 200 Series
State flags: 00000000

Device name: \\.\DISPLAY3
Device string: AMD Radeon R7 200 Series
State flags: 00000000

Device name: \\.\DISPLAY4
Device string: AMD Radeon R7 200 Series
State flags: 00000000

Device name: \\.\DISPLAY5
Device string: AMD Radeon R7 200 Series
State flags: 00000000

Device name: \\.\DISPLAY6
Device string: AMD Radeon R7 200 Series
State flags: 00000000

Device name: \\.\DISPLAY7
Device string: Intel(R) HD Graphics 4600
State flags: 00000000

Device name: \\.\DISPLAY8
Device string: Intel(R) HD Graphics 4600
State flags: 00000000

Device name: \\.\DISPLAY9
Device string: Intel(R) HD Graphics 4600
State flags: 00000000

=== Settings ===

Render Engine: d3d9
Audio Engine: xaudio2
Steam: true
Resolution: 1920 x 1200
Display Mode: fullscreen (1)
Vertical Sync: enabled (2)
Texture Resolution: high (3)
Texture Filter: anisotropic (3)
Shadow Quality: high (3)
SSAO Quality: high (3)
Rendering Quality: high (2)
Max Draw Distance: 1000.000000
Difficulty: normal
Oldschool Mode: false
Touchscreen Mode: false

Loading save game C:\Users\Royce\Documents/Almost Human/Legend of Grimrock 2/savegame19.sav
Loading main campaign dungeon
Game loaded

User avatar
Dr.Disaster
Posts: 2845
Joined: Wed Aug 15, 2012 11:48 am

Re: Launch issue

Post by Dr.Disaster » Wed Oct 03, 2018 9:54 pm

Going by your log
- you are running Win10
- you got more than one active GPU
- by the state flags the game uses your R7
- the game does launch
so in case there is a problem this log does not recognize it.

Since you're on Win10 i redirect you here: viewtopic.php?f=21&t=14723
Perhaps you can get a clue there.

Culturegeek
Posts: 9
Joined: Thu Apr 02, 2015 8:25 pm

Re: Launch issue

Post by Culturegeek » Mon Oct 08, 2018 3:43 pm

Cheers for the reply, and please excuse the probably remedial level of the questions I am going to be asking:
I found the event viewer, ran as admin. Here's the log:
SpoilerShow
Log Name: Application
Source: Application Error
Date: 10/8/2018 9:36:14 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: DESKTOP-RJ0A86M
Description:
Faulting application name: grimrock2.exe, version: 0.0.0.0, time stamp: 0x54ede8b1
Faulting module name: MSVCR100.dll, version: 10.0.40219.325, time stamp: 0x4df2be1e
Exception code: 0xc0000417
Fault offset: 0x0008af3e
Faulting process id: 0x24fc
Faulting application start time: 0x01d45f0be1ebcdc7
Faulting application path: D:\Program Files\Steam\steamapps\common\Legend of Grimrock 2\grimrock2.exe
Faulting module path: C:\WINDOWS\SYSTEM32\MSVCR100.dll
Report Id: 5e45e300-4f2d-4c0a-9ed7-887780dfd752
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2018-10-08T13:36:14.309554500Z" />
<EventRecordID>10737</EventRecordID>
<Channel>Application</Channel>
<Computer>DESKTOP-RJ0A86M</Computer>
<Security />
</System>
<EventData>
<Data>grimrock2.exe</Data>
<Data>0.0.0.0</Data>
<Data>54ede8b1</Data>
<Data>MSVCR100.dll</Data>
<Data>10.0.40219.325</Data>
<Data>4df2be1e</Data>
<Data>c0000417</Data>
<Data>0008af3e</Data>
<Data>24fc</Data>
<Data>01d45f0be1ebcdc7</Data>
<Data>D:\Program Files\Steam\steamapps\common\Legend of Grimrock 2\grimrock2.exe</Data>
<Data>C:\WINDOWS\SYSTEM32\MSVCR100.dll</Data>
<Data>5e45e300-4f2d-4c0a-9ed7-887780dfd752</Data>
<Data>
</Data>
<Data>
</Data>
</EventData>
</Event>
Do I need to create new user, and if so, how do I do that?

User avatar
Isaac
Posts: 2943
Joined: Fri Mar 02, 2012 10:02 pm

Re: Launch issue

Post by Isaac » Mon Oct 08, 2018 7:18 pm

Well the first thing to do—which you didn't mention, if you did it already, is to uninstall it, and install the latest build from your vendor [Steam/GoG/Direct...etc] . The installer will refresh the files, and try to update DirectX (on Windows). Before doing anything more involved (or invasive) to the system, see if that works; eliminate the possibility that it is the game which is corrupt.

Culturegeek
Posts: 9
Joined: Thu Apr 02, 2015 8:25 pm

Re: Launch issue

Post by Culturegeek » Mon Oct 08, 2018 8:55 pm

Thanks-- I'll give it a shot.

User avatar
Dr.Disaster
Posts: 2845
Joined: Wed Aug 15, 2012 11:48 am

Re: Launch issue

Post by Dr.Disaster » Mon Oct 08, 2018 9:00 pm

Culturegeek wrote:
Mon Oct 08, 2018 3:43 pm
Cheers for the reply, and please excuse the probably remedial level of the questions I am going to be asking:
I found the event viewer, ran as admin. Here's the log:

....
Faulting module name: MSVCR100.dll, version: 10.0.40219.325, time stamp: 0x4df2be1e
...
Going by your event viewer your Visual C++ Redistributable 2010 installation is faulty.
I would uninstall it, reboot and then reinstall this redistributable.

You can find the installers inside the game's _CommonRedist folder. Also let Steam check file integrity before running them.

Post Reply