Issues playing the game

Have trouble running Legend of Grimrock 2 or do you have questions about the purchasing options? Look for help here.
Post Reply
Simplybad
Posts: 3
Joined: Thu Jul 07, 2016 8:50 pm

Issues playing the game

Post by Simplybad » Thu Jul 07, 2016 9:00 pm

EDIT: I was unable to post dxdiag due to forum max characters limit so I will provide it if/when it is necessary



Hello! I recently built a computer and installed windows 10 and wanted to play through LoG2 again. But, I have been having issues getting the game to run and I believe it is directx related but I am unsure how to go about fixing this. First when I tried to run the game from Steam I got the error "d3derror createdevice failed:d3derr_invalidcall". My first thought was because of my native display setting being a little odd that it might be the issue so I changed to boot from windowed mode in the log. It was successful and booted the game but the window was very large compared to my display and I wanted to see if I could resize it or even go into fullscreen with the game loaded. When I tried to open the options menu in the home screen the game crashes again and I get the following error:

[string "lib/base.lua"]:0: bad argument #1 to 'find' (string expected, got nil)
stack traceback:
[C]: in function 'find'
[string "lib/base.lua"]: in function 'count'
[string "Gui.lua"]: in function 'drawTextCentered'
[string "Gui.lua"]: in function 'comboBox'
[string "Settings.lua"]: in function 'options'
[string "Settings.lua"]: in function 'update'
[string "GameMode.lua"]: in function 'update'
[string "Grimrock.lua"]: in function 'display'
[string "Grimrock.lua"]: in main chunk

I will provide the log file and my dxdiag in hopes it can help anyone solve my issues.

=== System Info ===

Game Version: 2.2.4
Computer name: DESKTOP-GH04ICC
CPU Vendor: GenuineIntel
CPU Brand: Intel(R) Core(TM) i5-3350P CPU @ 3.10GHz
OS Version: 6.2
OEM ID: 0
Physical CPUs: 4
Logical CPUs: 0
Page Size: 4096
Total Mem: 8141 MB
Free Mem: 5645 MB

=== GPUs ===

Device name: \\.\DISPLAY1
Device string: AMD Radeon HD 7900 Series
State flags: 08080005

Device name: \\.\DISPLAY2
Device string: AMD Radeon HD 7900 Series
State flags: 00080000

Device name: \\.\DISPLAY3
Device string: AMD Radeon HD 7900 Series
State flags: 00080000

Device name: \\.\DISPLAY4
Device string: AMD Radeon HD 7900 Series
State flags: 00080000

Device name: \\.\DISPLAY5
Device string: AMD Radeon HD 7900 Series
State flags: 00080000

Device name: \\.\DISPLAY6
Device string: AMD Radeon HD 7900 Series
State flags: 00080000

=== Settings ===

Render Engine: d3d9
Audio Engine: xaudio2
Steam: true
Resolution: 1360 x 768
Display Mode: ??? (0)
Vertical Sync: enabled (2)
Texture Resolution: high (3)
Texture Filter: anisotropic (3)
Shadow Quality: high (3)
SSAO Quality: high (3)
Rendering Quality: high (2)
Max Draw Distance: 1000.000000
Difficulty: normal
Oldschool Mode: false
Touchscreen Mode: false

=== Software Failure ===

[string "lib/base.lua"]:0: bad argument #1 to 'find' (string expected, got nil)
stack traceback:
[C]: in function 'find'
[string "lib/base.lua"]: in function 'count'
[string "Gui.lua"]: in function 'drawTextCentered'
[string "Gui.lua"]: in function 'comboBox'
[string "Settings.lua"]: in function 'options'
[string "Settings.lua"]: in function 'update'
[string "GameMode.lua"]: in function 'update'
[string "Grimrock.lua"]: in function 'display'
[string "Grimrock.lua"]: in main chunk

User avatar
Dr.Disaster
Posts: 2845
Joined: Wed Aug 15, 2012 11:48 am

Re: Issues playing the game

Post by Dr.Disaster » Thu Jul 07, 2016 9:38 pm

I've seen this LoG2 error message before. It turned out to be a corrupt "grimrock.cfg" file, prolly due to editing which left behind invisible characters. To resolve this delete the file and then start the game so it get's re-created with default values.

For reference: http://steamcommunity.com/app/251730/di ... 199278639/
Last edited by Dr.Disaster on Thu Jul 07, 2016 10:59 pm, edited 1 time in total.

Simplybad
Posts: 3
Joined: Thu Jul 07, 2016 8:50 pm

Re: Issues playing the game

Post by Simplybad » Thu Jul 07, 2016 10:47 pm

That unfortunately did not seem to fix it

User avatar
Dr.Disaster
Posts: 2845
Joined: Wed Aug 15, 2012 11:48 am

Re: Issues playing the game

Post by Dr.Disaster » Thu Jul 07, 2016 11:07 pm

This line
Simplybad wrote:Display Mode: ??? (0)
tells that there is something fishy going on with the game's config file.

The parameter "displayMode" is either 1 (default), 2 or 3; it's never 0 or anything else. Either your "grimrock.cfg" was manually tempered with or the game could not write the file correctly due to system interference i.e. insufficient access rights, bad user profile ...

Simplybad
Posts: 3
Joined: Thu Jul 07, 2016 8:50 pm

Re: Issues playing the game

Post by Simplybad » Fri Jul 08, 2016 2:16 am

I had said in the original post that I had manually changed the config file to boot in windowed mode, it was the only way I could get the game to successfully start without crashing. I just rechecked and the only thing I changed was the display from 1 to 0

minmay
Posts: 2654
Joined: Mon Sep 23, 2013 2:24 am

Re: Issues playing the game

Post by minmay » Fri Jul 08, 2016 4:06 am

Windowed mode is 2, not 0. Try that.
Grimrock 1 dungeon
Grimrock 2 resources
I no longer answer scripting questions in private messages. Please ask in a forum topic or this Discord server.

User avatar
Dr.Disaster
Posts: 2845
Joined: Wed Aug 15, 2012 11:48 am

Re: Issues playing the game

Post by Dr.Disaster » Fri Jul 08, 2016 4:20 am

On top of that do not use text processing programs to edit the config file. Use a plain text editor like Notepad to modify the config file.

Post Reply