[LINUX] The game wont start

Have trouble running Grimrock 1 or you're wondering if your graphics card is supported? Look for help here.
Sigmalion
Posts: 5
Joined: Fri Mar 20, 2015 5:15 pm

Re: [LINUX] The game wont start

Post by Sigmalion » Mon Mar 30, 2015 9:07 am

Nvidia 349.12 beta also is not working :(

Sigmalion
Posts: 5
Joined: Fri Mar 20, 2015 5:15 pm

Re: [LINUX] The game wont start

Post by Sigmalion » Sun Apr 12, 2015 10:08 pm

346.59 installed and nothing new... :roll:

saltima
Posts: 1
Joined: Mon May 04, 2015 3:48 am

Re: [LINUX] The game wont start

Post by saltima » Mon May 04, 2015 3:50 am

349 not working for me either and would be the best driver for GTX970

DHalfHorned
Posts: 6
Joined: Sat Jun 15, 2013 2:46 am

Re: [LINUX] The game wont start

Post by DHalfHorned » Fri May 29, 2015 9:13 pm

Created a workaround for this issue, you can download it from my google drive here: Grimrock_GTX900_Fix_(tested_up_to_349_16).tar.gz

Simply extract the 2 folders to your Grimrock folder (Select yes if asked about merging folders). If using the GOG version you have to go to "Legend of Grimrock/game".

Tested on both 32bit/64bit game binaries with a GTX 960 using 349.16 drivers.

Disclaimer: This is merely a workaround not a definite fix, I cannot guarantee it will not break at some point with more recent Nvidia drivers (hoping it won't).

UPDATE: Game still breaks with newest 352.21 drivers but the workaround still works.

FutureSuture
Posts: 2
Joined: Wed Jul 01, 2015 6:18 pm

Re: [LINUX] The game wont start

Post by FutureSuture » Wed Jul 01, 2015 8:29 pm

I bought this game at full price (11.99£ at the time) to show my appreciation of and support for Almost Human doing a Linux port of Legend of Grimrock. This problem was first reported on Steam on the 14th of February, 2015. Today is the 1st of July, 2015. 4 months and 18 days/19 weeks and 5 days/138 days later and absolutely no progress whatsoever. There has been no feedback from Almost Human on Legend of Grimrock's forum on Steam at all. These are all facts. Another fact is that I am severely disappointed. My first playthrough was rudely interrupted by this bug. I had never before played a game like Legend of Grimrock, but I thoroughly enjoyed what I managed to play before the game broke. I am considering asking for a refund since a game being broken for so long with no fix in sight is just too much of a joke on a decent customer. Having to register to get in touch with Almost Human here despite there being a link to the equivalent thread on Steam is irritating and poor customer service to boot.

User avatar
Dr.Disaster
Posts: 2845
Joined: Wed Aug 15, 2012 11:48 am

Re: [LINUX] The game wont start

Post by Dr.Disaster » Wed Jul 01, 2015 9:08 pm

FutureSuture wrote:I bought this game at full price (11.99£ at the time) to show my appreciation of and support for Almost Human doing a Linux port of Legend of Grimrock. This problem was first reported on Steam on the 14th of February, 2015. Today is the 1st of July, 2015. 4 months and 18 days/19 weeks and 5 days/138 days later and absolutely no progress whatsoever. There has been no feedback from Almost Human on Legend of Grimrock's forum on Steam at all. These are all facts. Another fact is that I am severely disappointed. My first playthrough was rudely interrupted by this bug. I had never before played a game like Legend of Grimrock, but I thoroughly enjoyed what I managed to play before the game broke. I am considering asking for a refund since a game being broken for so long with no fix in sight is just too much of a joke on a decent customer. Having to register to get in touch with Almost Human here despite there being a link to the equivalent thread on Steam is irritating and poor customer service to boot.
Well .. you are not entirely right in terms of feedback.

It's true that AH did not hand out feedback themselfs regarding this specific problem. Yet if you took a deeper look into the Steam threat you also posted in you might have seen this post made by me about a month ago:
Just got a heads up from Petri in this:

AH has tried hard to get the Linux porter to check into this problem but unfortunately the guy seems either no longer available or able to help. So for the moment there is no solution at hand :-/
This very reason is that the Linux porter who now can't or won't support his own work anymore is also a pretty heavy hit regarding any possible LoG 2 Linux port as i stated here one week later.

I'm absolutely certain if AH had the LoG 1 Linux source code and could find a trustworthy linux guy to add the needed changes they would. Yet the problem is finding such a person or - worst case - said source code.

FutureSuture
Posts: 2
Joined: Wed Jul 01, 2015 6:18 pm

Re: [LINUX] The game wont start

Post by FutureSuture » Thu Jul 02, 2015 3:22 pm

Dr.Disaster wrote:
FutureSuture wrote:I bought this game at full price (11.99£ at the time) to show my appreciation of and support for Almost Human doing a Linux port of Legend of Grimrock. This problem was first reported on Steam on the 14th of February, 2015. Today is the 1st of July, 2015. 4 months and 18 days/19 weeks and 5 days/138 days later and absolutely no progress whatsoever. There has been no feedback from Almost Human on Legend of Grimrock's forum on Steam at all. These are all facts. Another fact is that I am severely disappointed. My first playthrough was rudely interrupted by this bug. I had never before played a game like Legend of Grimrock, but I thoroughly enjoyed what I managed to play before the game broke. I am considering asking for a refund since a game being broken for so long with no fix in sight is just too much of a joke on a decent customer. Having to register to get in touch with Almost Human here despite there being a link to the equivalent thread on Steam is irritating and poor customer service to boot.
Well .. you are not entirely right in terms of feedback.

It's true that AH did not hand out feedback themselfs regarding this specific problem. Yet if you took a deeper look into the Steam threat you also posted in you might have seen this post made by me about a month ago:
Just got a heads up from Petri in this:

AH has tried hard to get the Linux porter to check into this problem but unfortunately the guy seems either no longer available or able to help. So for the moment there is no solution at hand :-/
This very reason is that the Linux porter who now can't or won't support his own work anymore is also a pretty heavy hit regarding any possible LoG 2 Linux port as i stated here one week later.

I'm absolutely certain if AH had the LoG 1 Linux source code and could find a trustworthy linux guy to add the needed changes they would. Yet the problem is finding such a person or - worst case - said source code.
Almost Human has only officially responded to this issue once and that was in this very thread. Although I appreciate the company passing on information through you, why on Earth can it not do so itself in public? In addition, a warning needs to be put up wherever Almost Human sells Legend of Grimrock; one that states that the game does not work on Nvidia's GeForce 900 series cards on Linux and therefore Steam Machines since the vast majority will be running such cards or newer. Surely after 4 months and 19 days/19 weeks and 6 days/139 days, if getting a hold of the Linux porter wasn't successful, other solutions could have been brought into place. That is, if the Almost Human cared, which many are speculating it does not. The company could learn to fix it itself rather than spend the aforementioned amount of time trying to get a hold of somebody who is busy, after all. At the end of the day, the onus lies on Almost Human to rectify the situation because, ultimately, it's up to the rights holder to be finding ways to deal with stuff if their contractors aren't getting things done.

User avatar
Dr.Disaster
Posts: 2845
Joined: Wed Aug 15, 2012 11:48 am

Re: [LINUX] The game wont start

Post by Dr.Disaster » Thu Jul 02, 2015 4:15 pm

I see your points. As a mere player - even a strong supporting one - i can't do much more than talk to others. On the other hand i can phrase things a bit more harsh then a developer would/should themselfs; i doubt AH would have stated the situation as i did ;)

Regarding a solution i see three options:
- get another guy to work in a patch which requires that entire linux source code is available
- get another guy to re-port the entire game
- try to find a solution with nVidia

A few months ago i already suspected a change regarding OpenGL support for Maxwell based cards causing the problem so checking back with nVidia should be considered. It would be interesting to know if Mac's running Maxwell based cards (Apple does not offer such combos for sale if i'm correct) face the same problem (here the game uses OpenGL too) to support my suspicion but until now i haven't heard of anyone running a Mac (or Hackintosh) with such a card yet.

User avatar
petri
Posts: 1898
Joined: Thu Mar 01, 2012 4:58 pm
Location: Finland

Re: [LINUX] The game wont start

Post by petri » Wed Jul 08, 2015 9:22 am

Apologies for the long delay!

We have just pushed a new Linux beta to Steam that should fix this issue. If you are on Steam, could you please test it by opting into the "linux_beta" branch (in Library -> Legend of Grimrock -> Properties -> Betas)?

If you're not a Steam user, here's a link to the patched executable (back up your previous executable!):
https://www.dropbox.com/s/dk1uxl2zv2ser ... n.x86?dl=0

I hope this finally solves this long standing issue.

DHalfHorned
Posts: 6
Joined: Sat Jun 15, 2013 2:46 am

Re: [LINUX] The game wont start

Post by DHalfHorned » Mon Jul 13, 2015 1:05 pm

petri wrote:Apologies for the long delay!

We have just pushed a new Linux beta to Steam that should fix this issue. If you are on Steam, could you please test it by opting into the "linux_beta" branch (in Library -> Legend of Grimrock -> Properties -> Betas)?

If you're not a Steam user, here's a link to the patched executable (back up your previous executable!):
https://www.dropbox.com/s/dk1uxl2zv2ser ... n.x86?dl=0

I hope this finally solves this long standing issue.
Hi Petri,

Wanted to give this a shot but it asks for the libsteam_api.so library, GOG and Humble Bundle versions don't have this file included and the game doesn't run without. Can you please provide a link to that? :-)

Thanks for your continued support, much appreciated.

------------------------

EDIT: I see you have already provided GOG the DRM-Free version :-)

This is just to let you know that it works perfectly on my 960, Thank you very much <3

Post Reply