[Linux] Editor doesn't export properly

Have trouble running Grimrock 1 or you're wondering if your graphics card is supported? Look for help here.
edgleyUK
Posts: 6
Joined: Wed Jan 23, 2013 3:37 pm
Location: UK
Contact:

Re: [Linux] Editor doesn't export properly

Post by edgleyUK » Tue Jan 29, 2013 1:44 pm

RaumSchiff wrote: --> Project created in a folder with no special caracters and exported in a folder with no special caracters
= Crash AFTER character creation.

--> Project created in default folder (with spaces) and exported in a folder with no special caracters OR default
= Crash In the "Choose Menu" BEFORE character creation.
It's not quite the same for me -- it makes no odds where I export it from or what the name of the file is etc (so regardless of special characters), I always get the crash *after* character creation.
RaumSchiff wrote: The error message is the same as yours in any cases ...
Software Failure, Error: File not found: mod_assets/scripts/init.lua
I have no problems of broken filesize though, in you case, the problem must be deeper.
No matter what I do to export it, I still end up with pretty much the same content of the file. Opening it in nano gives:

Code: Select all

GRA2^A^@^@^@����^\^@^@^@^@^@^@^@:^@^@^@^@^@^@^@^@^@^@^@^G^@^@^@testdun^F^@^@^@edgley^G^@^@^@Testing^R^@^@^@mod_assets/scripts
So the author, dungeon name and description are all exported, but after it gets to the scripts folder, it doesn't appear to include anything else.
RaumSchiff wrote: Anyway I still guess, ( wildly ??? :) ) this is a path problem.
Your binary is in "/mnt/games/grimrock/" and mine is in "/home/me/GAMES", ie: not standard (root) install paths.
I installed my version as standard user (not root). Perhaps you did the same.
Yep -- installed as standard user. Will try installing a clean copy as root when I get home, but I don't hold out much hope for it and it is far from being ideal.
RaumSchiff wrote: At least i can binary dump my .dat file with the od command :
My dungeon is description is "ffffff", I see also "mod_assets/scripts", But no idea with GRA2 ?

Code: Select all

me@home:~/.local/share/Almost Human/Legend of Grimrock/Dungeons$ od -c zz.dat 
0000000   G   R   A   2 001  \0  \0  \0 337 305 331 365 034  \0  \0  \0
0000020  \0  \0  \0  \0   0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
0000040 002  \0  \0  \0   z   z 003  \0  \0  \0   f   f   f 005  \0  \0
0000060  \0   f   f   f   f   f 022  \0  \0  \0   m   o   d   _   a   s
0000100   s   e   t   s   /   s   c   r   i   p   t   s
0000114
Pretty much identical for me -- description is "Testing":

Code: Select all

edgley@longbow Dungeons$ od testdun.dat -c
0000000   G   R   A   2 001  \0  \0  \0 337 305 331 365 034  \0  \0  \0
0000020  \0  \0  \0  \0   :  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
0000040  \a  \0  \0  \0   t   e   s   t   d   u   n 006  \0  \0  \0   e
0000060   d   g   l   e   y  \a  \0  \0  \0   T   e   s   t   i   n   g
0000100 022  \0  \0  \0   m   o   d   _   a   s   s   e   t   s   /   s
0000120   c   r   i   p   t   s
0000126
Thanks for the reply!

edgleyUK
Posts: 6
Joined: Wed Jan 23, 2013 3:37 pm
Location: UK
Contact:

Re: [Linux] Editor doesn't export properly

Post by edgleyUK » Wed Feb 06, 2013 3:22 am

Bump.

Anyone else have any suggestions?

andersdd
Posts: 1
Joined: Tue Jan 07, 2014 3:50 am

Re: [Linux] Editor doesn't export properly

Post by andersdd » Tue Jan 07, 2014 3:54 am

No crashes - just nothing exports when pressing the export menu

Running Ubuntu 13.10
Legend of Grimrock 1.3.7

EDIT : Got it working.

For future reference I had to make sure the export file was explicitly named including the .dat file suffix. File is exported to ${HOME}\.local\share\Almost Human\Legend of Grimrock\Dungeons.

Custom Dungeon is available from that location.

Can-ned Food
Posts: 2
Joined: Fri Jul 31, 2015 4:30 am

Re: [Linux] Editor doesn't export properly CORRECTED

Post by Can-ned Food » Tue Aug 25, 2015 11:41 pm

I thought I would close up this thread. The problem was that it didn't include subfolders when it compiled to the *.dat file.

Corrected with the 1.3.7 release. http://www.grimrock.net/2013/05/28/the- ... -on-steam/

Post Reply