Search found 426 matches

by NutJob
Wed Nov 26, 2014 3:26 am
Forum: Support and Tech Discussion
Topic: Mac Compatible?
Replies: 5
Views: 4483

Re: Mac Compatible?

The devs went to Amsterdam or something to party. They should be back soon.
by NutJob
Tue Nov 25, 2014 7:39 pm
Forum: Mod Creation
Topic: The "Has anyone got this code to work?" thread
Replies: 14
Views: 9635

Re: The "Has anyone got this code to work?" thread

Thanks Doridion, I can pretty much confirm using addConnector (on the correct field) on an item , only, will produce this error. I just tried added an event to many weapons, armor, and gear, starting with meleeattack on a long sword and I get map is nil . I use add/removeConnector() (not in the edit...
by NutJob
Tue Nov 25, 2014 1:24 am
Forum: Mod Creation
Topic: Debate: Secret buttons
Replies: 14
Views: 7300

Debate: Secret buttons

Well, this forum has died down significantly since a month a ago so how about some friendly crossfire on hidden buttons? To start, I'm an Anti-fan of hidden buttons unless in extremely reasonable circumstances, and even then will not use a Secret Button. If it's part of a puzzle or progression [of a...
by NutJob
Tue Nov 25, 2014 12:37 am
Forum: Mod Creation
Topic: [bug (nope, solved)] local spawn broken ?
Replies: 2
Views: 850

Re: [bug ?] local spawn broken ?

I dynamically create my entire module with spawn without setting a single entity in it [a map] (much like how Scotty does his in his procedural module). So, yes, spawn works and any property can be changed, removed, and added (createComponent), and no, I don't lose "settings/values" on the objects c...
by NutJob
Mon Nov 24, 2014 11:33 pm
Forum: Mod Creation
Topic: The "Has anyone got this code to work?" thread
Replies: 14
Views: 9635

Re: The "Has anyone got this code to work?" thread

Aye, yes. The first thing I did when I got the map is nil error was this: function specialRope(x, y, z, facing) local o = spawn("rope", party.level, x, y, facing, z) print(o.map) o.item:addConnector("onEquipItem", "lib", "aaa") o.item:addConnector("onUnequipItem", "lib", "bbb") print(o.map) end Both...
by NutJob
Mon Nov 24, 2014 11:00 pm
Forum: Mod Creation
Topic: The "Has anyone got this code to work?" thread
Replies: 14
Views: 9635

Re: The "Has anyone got this code to work?" thread

Here is the stripped down testing code that gets fired on a floor_trigger: function myTestSpawn() local o = spawn("rope", party.level, party.x, party.y, 0, party.elevation) o.item:addConnector("onEquipItem", "lib", "aaa") o.item:addConnector("onUnequipItem", "lib", "bbb") end function aaa() print("A...
by NutJob
Mon Nov 24, 2014 10:28 pm
Forum: Mod Creation
Topic: The "Has anyone got this code to work?" thread
Replies: 14
Views: 9635

Re: The "Has anyone got this code to work?" thread

For the sake of testing I moved the whole thing to a floor_trigger partyOnly. Edit: also because all 4 of my scripts (238 functions) are loaded from a single script_entity with this amazing script loader nothing gets fired before everything else is loaded into the game. I used to have problems with ...
by NutJob
Mon Nov 24, 2014 9:01 pm
Forum: Mod Creation
Topic: The "Has anyone got this code to work?" thread
Replies: 14
Views: 9635

Re: The "Has anyone got this code to work?" thread

All right, well, I guess I'll chalk this up to "not possible" and stick with directly putting the functions in the defineObject: defineObject{ baseObject = "base_item", name = "someItemWithEvents", components = { { class = "Item", onEquipItem = function(self, champion, slot) print(self, champion, sl...
by NutJob
Mon Nov 24, 2014 8:48 pm
Forum: Mod Creation
Topic: The "Has anyone got this code to work?" thread
Replies: 14
Views: 9635

Re: The "Has anyone got this code to work?" thread

Initialization (instantiation?) is not from a calling object so it never occurred to me (I'm directly working with the object). Also, no that doesn't work; decided to try anyway being I'm on attempt #6,209 (not really) to make it work.