Search found 48 matches

by vieuxchat
Sun Feb 19, 2017 8:17 pm
Forum: Mod Creation
Topic: Optimization of a script
Replies: 15
Views: 7758

Re: Optimization of a script

Yes ! So, that's it.
Thanks for the thread, it is very useful :)
by vieuxchat
Sun Feb 19, 2017 4:18 pm
Forum: Mod Creation
Topic: Optimization of a script
Replies: 15
Views: 7758

Re: Optimization of a script

Thanks for the info about light, it's very useful.

Another people has the same slow down but without having its video card doing any noise. So it may be not what I thought it was.
I may have another hint : does a fireball "dies" if it doesn't hit anything ?
by vieuxchat
Sun Feb 19, 2017 10:00 am
Forum: Mod Creation
Topic: Optimization of a script
Replies: 15
Views: 7758

Re: Optimization of a script

So the range and the shadows are the culprit. What represents 24 m ingame ? 24 cells ? 12 ? 8 ? All lights are in reachable places in the castle, so impostering wouldn't give good results. In fact I'm not sure I really understand what is the difference between a directionnal light and a point one. W...
by vieuxchat
Sat Feb 18, 2017 11:12 pm
Forum: Mod Creation
Topic: Optimization of a script
Replies: 15
Views: 7758

Re: Optimization of a script

The lights are used to illuminate the interior of a castle with "natural" light (the exact light of the day) So, when it is midnight, the lights are dimmed, and when it's midday they are "high". I put those lights on the verge of the map (where there's windows). Sometimes, to get the best effect, I ...
by vieuxchat
Sat Feb 18, 2017 9:41 pm
Forum: Mod Creation
Topic: Optimization of a script
Replies: 15
Views: 7758

Re: Optimization of a script

I feared that.
Those 100 lights add a lot to the mood of the level, I'll probably have to reduce the frequency of that script.

But is there a way to reduce the memory footprint of those lights ?

@zimberzimber : I don't understand why your solution would be faster than my script.
by vieuxchat
Sat Feb 18, 2017 7:57 pm
Forum: Mod Creation
Topic: Optimization of a script
Replies: 15
Views: 7758

Optimization of a script

In my mod, several players said that one of my level was slowed down a lot. Here is probably the culprit : function MAJ() local r,g,b = castle_arena_sky_1.light:getColor() for i =1,100 do local entity = findEntity("lumieres_fenetre_minimal_save_state_"..i) if entity ~= nil then entity.light:setColor...
by vieuxchat
Sun Jan 22, 2017 7:48 pm
Forum: Mod Creation
Topic: Thank you
Replies: 0
Views: 3276

Thank you

I wanted to publicly thank Minmay and Isaac for their help (and all the others that helped me).
I wouldn't have finished my module without their answers to my numerous questions.
Also thank you for the GitHub Wiki (https://github.com/JKos/log2doc/wiki), the technical informations are priceless.
by vieuxchat
Thu Nov 24, 2016 7:57 am
Forum: Mod Creation
Topic: Load a save after updating a dungeon
Replies: 5
Views: 2495

Re: Load a save after updating a dungeon

When you reload a savegame, the dungeon.lua is not run again. The savegame contains all the information about object and component placement and state. So if you change object placements, ScriptComponent source, whatever, your changes will NOT apply to old savegames. Only changes to other files (as...
by vieuxchat
Wed Nov 23, 2016 7:58 pm
Forum: Mod Creation
Topic: Load a save after updating a dungeon
Replies: 5
Views: 2495

Load a save after updating a dungeon

I saved a game in my dungeon. Then I changed a script (some lines of code). Then I load the save and the changes I made aren't there. The save game still load the old script. When I load the save it asks me if I want as the version number isn't the same. So I thought it was the new script that shoul...
by vieuxchat
Fri Aug 26, 2016 5:26 pm
Forum: Mod Creation
Topic: Particle not re-enabling
Replies: 2
Views: 1839

Re: Particle not re-enabling

I tried with restart, but it didn't work. I didn't thought of fadeIn ! And that made the trick :D
Thank you very much :)

It seems the restart doesn't change the "alpha" channel of the particles. I guess the particles were enabled, but still at 0 in alpha.